Having WordPress Trouble Due to v4.4? Here’s the Fix.

December 9, 2015 Posted by Tyler Cruz

I just updated WordPress to v4.4 this morning but upon doing so, I started to receive errors when I attempted to upgrade my themes.

Apparently you can also get the error when you try to upgrade plugins, or use certain features of WordPress.

Apparently others are having this issue too, but it took a bit of Googling to find a fix for it.

Below is a link to the original site I found that lead me to the fix:

http://myonlinesecurity.co.uk/wordpress-4-4-update-breaks-itself-with-ssl-certificate-problem-unable-to-get-local-issuer-certificate/

Here’s an excerpt:

WordPress4.4 has just been released and it is highly recommended to update. BUT it is broken on many servers.  The update will go OK but it will also update the SSL certificate bundle that WordPress uses to update itself, the themes and plugins. The certificate bundle appears to be damaged or incorrect and stops any WP updates

You will get a message saying http_request_failed: “SSL certificate problem: unable to get local issuer certificate” whenever you try to do anything involving WordPress updates, updating or installing themes or plugins or using Jetpack features like stats or sharing etc.

You can also get this error with many other plugins that use SSL to communicate for functionality like sending emails or even posting to twitter or Facebook etc. .  Mailchimp is one that comes to mind

Anyhow, the fix was just posted 20 hours ago thanks to WPChina on the WordPress support boards who posted:

Go to http://curl.haxx.se/ca/cacert.pem and save it as ca-bundle.crt

Upload this file to: wp-includes/certificates/ca-bundle.crt

Remember that any update WordPress does will overwrite this. So until WordPress fixes/updates themselves, you should manually do this yourself.

I wish WordPress could send out a hotfix of some sort now to make this update. Updated certs is very important for security and communication between sites.

I followed the above directions and it fixed everything for me. Just thought I’d share this for all my fellow WordPress bloggers out there who may be having the same issue!

If you enjoyed this post, please consider leaving a comment below, subscribing to my RSS feed, or following me on Twitter.
Posted: December 9th, 2015 under Miscellaneous  

9 Responses to “Having WordPress Trouble Due to v4.4? Here’s the Fix.”

  1. Barry says:

    I updated my WordPress and I am no longer able to edit posts in my Visual editor. This is so strange. 🙁

  2. Ravi Kumar says:

    This fix doesn’t work in all cases. Me and my friend was also facing the same issue. I tried this fix on my friend’s blog and worked like a charm. However, the same fix failed to work for me.

    At the end, I downgraded my WordPress version to make things working again.

    Everytime, WordPress brings any update, we blogger face new issues. However, handling errors is a part of our life and i enjoy fixing issues.

    Anyway, thanks for this tutorial.

  3. ChrisBa says:

    I haven’t had any issues yet, but good to know if I do, there’s a fix

  4. Juthan says:

    Thanks for the tutorial Tyler will use this

  5. Mnaihs Saini says:

    thanks for this awesome tip. this is really helpful for me 🙂

  6. Thank you for this….. it needs sharing sharing and more sharing…. just fixed my WordPress site finally 🙂

  7. shaun says:

    hey tyler,

    Thanks for this quality information, I spend a lot of time on your site and really like your content!!

    Shaun

  8. DeledNios says:

    Nic Post….. Sir,,,, This is very Informative site. its very helpful for us….

  9. Nice post,,,thats really amazing,,,

PeerFly

Leave a Reply to Juthan